User ID
 
Password
 
Register Forgot password

#### Notice: New server Optimus is Online! Informations, click HERE ####
content_top

Back to Guides: Click Here

How to fix Power Up Store Hata & Script Errors (PUS)

If you are facing Script Error in our PUS this means your
Flash Player & Internet Explorer version is not supported.

HOW TO FIX IT?

To fix the issue you need to upgrade your Adobe Flash Player & Internet Explorer
version to 9 or above, we suggest Internet Explorer version 11.

CLICK HERE to download and install Internet Explorer 11
for Windows 7 Operating System.

CLICK HERE to download and install Internet Explorer 11
update for Windows 8.1 Operating System.

CLICK HERE to Download and install Adobe Flash Player.

Back to Guides: Click Here

Copyright 2018 by ProjectKO - All rights reserved. Janek was helping with upgrade panel!